Главы  1  2  

Пошаговое вычисление формул



Пошаговое вычисление формул

Даже если формула введена правильно, может быть неправильно выбран порядок функций и операций, что не позволит получить нужный результат. Средство «Вычисление формулы» позволяет вычислить отдельные части формулы (особенности сложных формул), чтобы можно было определить, в какой части формулы содержится ошибка.

Вычисление формул подобно использованию средств отладки в среде программирования. Вычисление формулы можно осуществлять пошагово, самостоятельно выбирая вычисляемую часть формулы.

Допустим, в ячейку D5 введена следующая формула:

=ЕСЛИ(СРЗНАЧ(B2:B5)<50,СУММC2:C5),0)

Если среднее значение диапазона ячеек B2:B5 не превышает 50, тогда вне зависимости от результата суммирования значений ячеек в диапазоне C2:C5 в качестве результата этой формулы будет выведено значение 0.

Для пошагового вычисления формулы можно использовать средство «Вычисление формулы». Например, при первом открытии диалогового окна Вычисление формулы первое выражение в формуле будет подчеркнуто следующим образом:

=ЕСЛИ(СРЗНАЧ(B2:B5)<50,СУММ(C2:C5),0)

При нажатии кнопки Вычислить будет вычислено значение подчеркнутого выражения, а результат выведен следующим образом (предполагается, что в ячейках диапазона B2:B5 содержатся следующие значения: 51, 49,39, и 68):

=ЕСЛИ(51,75<50,СУММ(C2:C5),0)

Снова нажмите кнопку Вычислить и обратите внимание, что поскольку 51,75 больше 50, выражению возвращается логическое значение ЛОЖЬ:

=ЕСЛИ(ЛОЖЬ,СУММ(C2:C5),0)

Пока этому выражению возвращается логическое значение ЛОЖЬ, вся формула будет возвращать нулевое значение.

Чтобы вычислить формулу, выберите в меню Сервис команду Зависимости формул и подкоманду Вычислить формулу.



- Начало - - Назад - - Вперед -